SecurityBrief NZ - Meet the encryption flaw that's putting internet users at risk

Warning: This story was published more than a year ago.
security.jpg

Meet the encryption flaw that's putting internet users at risk

LogJam is a new encryption flaw that is putting a significant number of internet users' data at risk, affecting websites, mail servers, and other frequently-used internet services.

It allows an attacker to weaken what is believed to be a secure encrypted connection between a user and a server, according to a statement from Trend Micro.

In essence, this weakness could be used to empower a cybercriminal with the right resources to mount a man-in-the-middle attack to sniff on and modify communications that are known to be ‘secure’.

Matthew Green, cryptographer and professor at John Hopkins University, along with a group of researchers,says this flaw harks back to the 1990s and is an indirect offshoot of a US-government mandate to limit the levels of encryption of products exported abroad to allow them to easily spy on enemies.

Decades after the policy was lifted, the gates remain unsealed.

According to the site put up by the researchers, 8.4% of the top one million domains, as well as a significant number of existing email servers that support SMTP with StartTLS, POP3S, and IMAPS, have been identified as vulnerable to this weakness.

LogJam’s activities are reminiscent of the FREAK vulnerability discovered in March.

FREAK forces a secure connection to utilise weaker encryption that makes it easy for cybercriminals to pounce on sensitive information.

Green and his fellow researchers have determined the problem in a weakness found on the Diffie-Hellman key exchange, says Trend Micro.

Websites and email servers make use of SSL (Secure Sockets Layer) or TLS (Transport Layer Security) protocols to create a secure connection among users.

The Diffie-Hellman key exchange is primarily responsible for the communication and exchange of encryption keys that are used to secure a connection.

The LogJam attack makes it easy to lower TLS connections to the level of those that use 512-bit ‘export-grade’ encryption.

In turn, cybercriminals can dupe a server into accepting weaker encryption, thinking it is secure enough.

This then gives them the chance to intercept the data that passes through the connection.

At present, researchers have indicated major browsers by Mozilla, Google, Microsoft, and Apple, among others, are working on fixes to address this vulnerability.

This issue brings to the fore the importance of keeping systems up to date not just for end users but for software developers as well, says Trend Micro.

IT administrators using servers that are known to use any of the services and protocols at risk are advised to disable support for all export cipher suites to thwart attempts for compromise, and prevent using Diffie-Hellman key exchange lower than 2048-bits to steer clear of possible interception.

Internet users are likewise advised to make sure that browsers are up to date, and to check for updates frequently.

Interested in this topic?
We can put you in touch with an expert.

BRAND SPONSORS

Follow Us

Featured

next-story-thumb Scroll down to read: